NASASpaceFlight.com Forum

NSF Landing Page (Site Rules, Overviews Development, Feedback) => NASASpaceflight.com and NSF Forum Site Rules/News => Topic started by: Chris Bergin on 02/03/2018 02:25 pm

Title: Forum logging in with mobile/Tapatalk
Post by: Chris Bergin on 02/03/2018 02:25 pm
We're aware some people have an issue with this.

Until it's resolved, please select "full site" and login via that version. Will update this thread when the mobile/tapatalk version is resolved.

"Desktop" (normal site) is unaffected.

UPDATE:
Mobile version should be fixed now. Please report back if you had an issue and now fixed.
Mark says Tapatalk may still need more work.
Title: Re: Forum logging in with mobile/Tapatalk
Post by: Johnnyhinbos on 02/03/2018 02:47 pm
UPDATE: My account is now working in Tapatalk! Don't know what changed - maybe on the server end?

BACKGROUND: I've been having issues for the past day and a half with my NSF login and Tapatalk. Unable to post anywhere (I'm a L2 subscriber, for what it's worth). Unread doesn't show anything. Clicking any post in Timeline always takes me to the #1 post in thread, every time (hugely annoying).

Troubleshooting steps:
- Logged out and in
- Cleared Tapatalk cache
- Unfollowed NSF then re-added it
- Delete entire app and reinstalled
- Tried logging in on my iPad (same issues)

Nothing made a difference.

Then (just now) I created a new registration using the full site on my computer. Created user "Izzy_Hanzl". Used that to log into Tapatalk on my iPhone. Was able to create a post with that account. Unread worked. Etc. I then switched accounts in Tapatalk and logged back in as me (johnnyhinbos). Now everything works.

Not sure if it was my doing, of just a coincidence. Regardless, it works!

Oh - and Chris, if you're reading this, please feel free to delete user Izzy_Hanzl (sorry, but my dog doesn't really read this forum...)


Title: Re: Forum logging in with mobile/Tapatalk
Post by: Chris Bergin on 02/03/2018 02:57 pm
I'd prefer it if Mark finds a blanket fix, but that will be helpful for his troubleshooting! :)
Title: Re: Forum logging in with mobile/Tapatalk
Post by: Chris Bergin on 02/03/2018 03:22 pm
UPDATE:
Mobile version should be fixed now. Please report back if you had an issue and now fixed.
Mark says Tapatalk may still need more work.
Title: Re: Forum logging in with mobile/Tapatalk
Post by: Jakusb on 02/03/2018 03:28 pm
UPDATE:
Mobile version should be fixed now. Please report back if you had an issue and now fixed.
Mark says Tapatalk may still need more work.

I can confirm Tapatalk is working again!
Great work! Thanks.
Title: Re: Forum logging in with mobile/Tapatalk
Post by: Star One on 02/03/2018 10:15 pm
Tapatalk seems to be working again. Wonder what the heck it was objecting too?
Title: Re: Forum logging in with mobile/Tapatalk
Post by: Johnnyhinbos on 02/03/2018 10:17 pm
Iím going to vote for Tapatalk server cache expiring times...


Sent from my iPhone using Tapatalk Pro
Title: Re: Forum logging in with mobile/Tapatalk
Post by: NSF Webmaster on 02/03/2018 10:30 pm
With the move to SSL (by default) and some security patches on the forum software side (SMF) regarding the login flow it turned out that the mobile and Tapatalk login pages weren't properly updated. Sessions originating from those pages were rejected until the fix was also applied on those login methods.

The switch to SSL forced almost everybody to lose his/her session, the number of people experiencing issues with earlier introduced issues on the mobile/TT login spiked as a result from that.

Right now everything should be working again for everyone. Please let us know if you (still) experience issues.

Mark
Title: Re: Forum logging in with mobile/Tapatalk
Post by: Johnnyhinbos on 02/06/2018 01:19 pm
I am fully locked out ot the forum in Tapatalk. Nothing shows up in Unread, nothing shows up in Timeline, and it says I am no longer logged in. When I try to log in I get a huge error.

Not a good day for this. Anyone else having issues?

Also, if I try to view forum without being logged in I get the second screen shot...
Title: Re: Forum logging in with mobile/Tapatalk
Post by: techdude06 on 02/06/2018 01:33 pm
I am having issues with Taptalk as well. I can't Login to NSF anymore.
Title: Re: Forum logging in with mobile/Tapatalk
Post by: NSF Webmaster on 02/06/2018 01:36 pm
The screenshots show your issue, so I'm further investigating but I can login on two phones succesfully (ios & android).
Title: Re: Forum logging in with mobile/Tapatalk
Post by: techdude06 on 02/06/2018 01:39 pm
The screenshots show your issue, so I'm further investigating but I can login on two phones succesfully (ios & android).

I am using a GS7 Edge - the taptalk app did update this morning, I don't know if that is the cause.

Thanks
Title: Re: Forum logging in with mobile/Tapatalk
Post by: Johnnyhinbos on 02/06/2018 01:43 pm
The screenshots show your issue, so I'm further investigating but I can login on two phones succesfully (ios & android).
My iPhone decided to upgrade to 11.2.5 while I was sleeping last night. Perhaps thatís the commonality?
Title: Re: Forum logging in with mobile/Tapatalk
Post by: cscott on 02/06/2018 02:32 pm
Tapatalk still broken for me on Android. :( My app was last updated Jan 8, so I'm pretty sure it's not a buggy app version.

I even 'unfollowed' NSF and re-added it to Tapatalk using the https link on the NSF front page, and no change.

I'm a little worried that my remove-and-retry antics are going to end up wiping tapatalk's list of subscribed forums, which is the #1 way I browse the site.  Does anyone know of/how I can see my list of subscribed forums on the desktop site?

EDIT: just retried, and it worked! I don't know if Mark fixed something or it was a bad cache entry that finally expired, but I'm a happy camper again on FH day.  Thanks!
Title: Re: Forum logging in with mobile/Tapatalk
Post by: NSF Webmaster on 02/06/2018 02:44 pm
Tapatalk still broken for me on Android. :( My app was last updated Jan 8, so I'm pretty sure it's not a buggy app version.

I even 'unfollowed' NSF and re-added it to Tapatalk using the https link on the NSF front page, and no change.

I'm a little worried that my remove-and-retry antics are going to end up wiping tapatalk's list of subscribed forums, which is the #1 way I browse the site.  Does anyone know of/how I can see my list of subscribed forums on the desktop site?

EDIT: just retried, and it worked! I don't know if Mark fixed something or it was a bad cache entry that finally expired, but I'm a happy camper again on FH day.  Thanks!

are you available for a little bit of troubleshooting to pinpoint the root cause ? I still can't reproduce it locally but really like to find out what change might have triggered this behaviour.

Thanks
Mark
Title: Re: Forum logging in with mobile/Tapatalk
Post by: techdude06 on 02/06/2018 02:46 pm
Tapatalk still broken for me on Android. :( My app was last updated Jan 8, so I'm pretty sure it's not a buggy app version.

I even 'unfollowed' NSF and re-added it to Tapatalk using the https link on the NSF front page, and no change.

I'm a little worried that my remove-and-retry antics are going to end up wiping tapatalk's list of subscribed forums, which is the #1 way I browse the site.  Does anyone know of/how I can see my list of subscribed forums on the desktop site?

EDIT: just retried, and it worked! I don't know if Mark fixed something or it was a bad cache entry that finally expired, but I'm a happy camper again on FH day.  Thanks!



Just started working for me as well.

Thanks!
Title: Re: Forum logging in with mobile/Tapatalk
Post by: cscott on 02/06/2018 02:48 pm
Tapatalk still broken for me on Android. :( My app was last updated Jan 8, so I'm pretty sure it's not a buggy app version.

I even 'unfollowed' NSF and re-added it to Tapatalk using the https link on the NSF front page, and no change.

I'm a little worried that my remove-and-retry antics are going to end up wiping tapatalk's list of subscribed forums, which is the #1 way I browse the site.  Does anyone know of/how I can see my list of subscribed forums on the desktop site?

EDIT: just retried, and it worked! I don't know if Mark fixed something or it was a bad cache entry that finally expired, but I'm a happy camper again on FH day.  Thanks!

are you available for a little bit of troubleshooting to pinpoint the root cause ? I still can't reproduce it locally but really like to find out what change might have triggered this behaviour.

Thanks
Mark
Well, it's working for me again, so I maybe can't help any more.  But if you log unsuccessful logins, there should be about a dozen trying both by username (cscott) and my forum email address.  Other than maybe one or two at the start (before I switched over to the desktop site to verify that I was remembering my password correctly) they should all be legit logins. I'd love to know what the logged reason was for denying login.  And if your logs don't show any failed attempts at all, well that's another possible interesting symptom.
Title: Re: Forum logging in with mobile/Tapatalk
Post by: NSF Webmaster on 02/06/2018 02:50 pm
Tapatalk still broken for me on Android. :( My app was last updated Jan 8, so I'm pretty sure it's not a buggy app version.

I even 'unfollowed' NSF and re-added it to Tapatalk using the https link on the NSF front page, and no change.

I'm a little worried that my remove-and-retry antics are going to end up wiping tapatalk's list of subscribed forums, which is the #1 way I browse the site.  Does anyone know of/how I can see my list of subscribed forums on the desktop site?

EDIT: just retried, and it worked! I don't know if Mark fixed something or it was a bad cache entry that finally expired, but I'm a happy camper again on FH day.  Thanks!




are you available for a little bit of troubleshooting to pinpoint the root cause ? I still can't reproduce it locally but really like to find out what change might have triggered this behaviour.

Thanks
Mark
Well, it's working for me again, so I maybe can't help any more.  But if you log unsuccessful logins, there should be about a dozen trying both by username (cscott) and my forum email address.  Other than maybe one or two at the start (before I switched over to the desktop site to verify that I was remembering my password correctly) they should all be legit logins. I'd love to know what the logged reason was for denying login.  And if your logs don't show any failed attempts at all, well that's another possible interesting symptom.

Thanks for the follow up.. I'll leave the settings the way they are for now, but I might contact one of you tomorrow (after FH :) ) to troubleshoot/test some things

Thanks
Title: Re: Forum logging in with mobile/Tapatalk
Post by: starsilk on 02/06/2018 03:07 pm
working for me again too. was down this AM.
Title: Re: Forum logging in with mobile/Tapatalk
Post by: clevelas on 02/06/2018 04:51 pm
I was asked to login on tapatalk this morning as well.  Then gave some crazy error.  Hopped on a desktop browser, and had a gateway error being reported by Cloudflare.  Saying the backend server was unavailable.  It was down probably 10 minutes or so.  Once the site came back up, Tapatalk started working as well.   So there was more to it today than just tapatalk.
Title: Re: Forum logging in with mobile/Tapatalk
Post by: tyrred on 02/06/2018 04:53 pm
402 bad gateway for me as well on Tapatalk, had me sweating... All systems go now, no new login necessary on my end.
Title: Re: Forum logging in with mobile/Tapatalk
Post by: Johnnyhinbos on 02/06/2018 05:01 pm
I'm back up as well. Would be interested to know what you did to effect a fix.