Author Topic: Forum logging in with mobile/Tapatalk  (Read 4059 times)

Offline Chris Bergin

Forum logging in with mobile/Tapatalk
« on: 02/03/2018 02:25 PM »
We're aware some people have an issue with this.

Until it's resolved, please select "full site" and login via that version. Will update this thread when the mobile/tapatalk version is resolved.

"Desktop" (normal site) is unaffected.

UPDATE:
Mobile version should be fixed now. Please report back if you had an issue and now fixed.
Mark says Tapatalk may still need more work.
« Last Edit: 02/03/2018 03:22 PM by Chris Bergin »

Offline Johnnyhinbos

  • Full Member
  • ****
  • Posts: 1377
  • Boston, MA
  • Liked: 1602
  • Likes Given: 222
Re: Forum logging in with mobile/Tapatalk
« Reply #1 on: 02/03/2018 02:47 PM »
UPDATE: My account is now working in Tapatalk! Don't know what changed - maybe on the server end?

BACKGROUND: I've been having issues for the past day and a half with my NSF login and Tapatalk. Unable to post anywhere (I'm a L2 subscriber, for what it's worth). Unread doesn't show anything. Clicking any post in Timeline always takes me to the #1 post in thread, every time (hugely annoying).

Troubleshooting steps:
- Logged out and in
- Cleared Tapatalk cache
- Unfollowed NSF then re-added it
- Delete entire app and reinstalled
- Tried logging in on my iPad (same issues)

Nothing made a difference.

Then (just now) I created a new registration using the full site on my computer. Created user "Izzy_Hanzl". Used that to log into Tapatalk on my iPhone. Was able to create a post with that account. Unread worked. Etc. I then switched accounts in Tapatalk and logged back in as me (johnnyhinbos). Now everything works.

Not sure if it was my doing, of just a coincidence. Regardless, it works!

Oh - and Chris, if you're reading this, please feel free to delete user Izzy_Hanzl (sorry, but my dog doesn't really read this forum...)


John Hanzl. Author, action / adventure www.johnhanzl.com

Offline Chris Bergin

Re: Forum logging in with mobile/Tapatalk
« Reply #2 on: 02/03/2018 02:57 PM »
I'd prefer it if Mark finds a blanket fix, but that will be helpful for his troubleshooting! :)

Offline Chris Bergin

Re: Forum logging in with mobile/Tapatalk
« Reply #3 on: 02/03/2018 03:22 PM »
UPDATE:
Mobile version should be fixed now. Please report back if you had an issue and now fixed.
Mark says Tapatalk may still need more work.

Online Jakusb

  • Full Member
  • ****
  • Posts: 870
  • NL
  • Liked: 634
  • Likes Given: 329
Re: Forum logging in with mobile/Tapatalk
« Reply #4 on: 02/03/2018 03:28 PM »
UPDATE:
Mobile version should be fixed now. Please report back if you had an issue and now fixed.
Mark says Tapatalk may still need more work.

I can confirm Tapatalk is working again!
Great work! Thanks.

Offline Star One

  • Senior Member
  • *****
  • Posts: 9643
  • UK
  • Liked: 1819
  • Likes Given: 183
Re: Forum logging in with mobile/Tapatalk
« Reply #5 on: 02/03/2018 10:15 PM »
Tapatalk seems to be working again. Wonder what the heck it was objecting too?

Offline Johnnyhinbos

  • Full Member
  • ****
  • Posts: 1377
  • Boston, MA
  • Liked: 1602
  • Likes Given: 222
Re: Forum logging in with mobile/Tapatalk
« Reply #6 on: 02/03/2018 10:17 PM »
Iím going to vote for Tapatalk server cache expiring times...


Sent from my iPhone using Tapatalk Pro
John Hanzl. Author, action / adventure www.johnhanzl.com

Offline NSF Webmaster

  • Administrator
  • Full Member
  • *****
  • Posts: 330
  • Almere, The Netherlands
    • NASASpaceFlight.com
  • Liked: 146
  • Likes Given: 14
Re: Forum logging in with mobile/Tapatalk
« Reply #7 on: 02/03/2018 10:30 PM »
With the move to SSL (by default) and some security patches on the forum software side (SMF) regarding the login flow it turned out that the mobile and Tapatalk login pages weren't properly updated. Sessions originating from those pages were rejected until the fix was also applied on those login methods.

The switch to SSL forced almost everybody to lose his/her session, the number of people experiencing issues with earlier introduced issues on the mobile/TT login spiked as a result from that.

Right now everything should be working again for everyone. Please let us know if you (still) experience issues.

Mark

Offline Johnnyhinbos

  • Full Member
  • ****
  • Posts: 1377
  • Boston, MA
  • Liked: 1602
  • Likes Given: 222
Re: Forum logging in with mobile/Tapatalk
« Reply #8 on: 02/06/2018 01:19 PM »
I am fully locked out ot the forum in Tapatalk. Nothing shows up in Unread, nothing shows up in Timeline, and it says I am no longer logged in. When I try to log in I get a huge error.

Not a good day for this. Anyone else having issues?

Also, if I try to view forum without being logged in I get the second screen shot...
« Last Edit: 02/06/2018 01:33 PM by Johnnyhinbos »
John Hanzl. Author, action / adventure www.johnhanzl.com

Online techdude06

  • Member
  • Posts: 12
  • Ohio
  • Liked: 6
  • Likes Given: 3
Re: Forum logging in with mobile/Tapatalk
« Reply #9 on: 02/06/2018 01:33 PM »
I am having issues with Taptalk as well. I can't Login to NSF anymore.

Offline NSF Webmaster

  • Administrator
  • Full Member
  • *****
  • Posts: 330
  • Almere, The Netherlands
    • NASASpaceFlight.com
  • Liked: 146
  • Likes Given: 14
Re: Forum logging in with mobile/Tapatalk
« Reply #10 on: 02/06/2018 01:36 PM »
The screenshots show your issue, so I'm further investigating but I can login on two phones succesfully (ios & android).

Online techdude06

  • Member
  • Posts: 12
  • Ohio
  • Liked: 6
  • Likes Given: 3
Re: Forum logging in with mobile/Tapatalk
« Reply #11 on: 02/06/2018 01:39 PM »
The screenshots show your issue, so I'm further investigating but I can login on two phones succesfully (ios & android).

I am using a GS7 Edge - the taptalk app did update this morning, I don't know if that is the cause.

Thanks

Offline Johnnyhinbos

  • Full Member
  • ****
  • Posts: 1377
  • Boston, MA
  • Liked: 1602
  • Likes Given: 222
Re: Forum logging in with mobile/Tapatalk
« Reply #12 on: 02/06/2018 01:43 PM »
The screenshots show your issue, so I'm further investigating but I can login on two phones succesfully (ios & android).
My iPhone decided to upgrade to 11.2.5 while I was sleeping last night. Perhaps thatís the commonality?
John Hanzl. Author, action / adventure www.johnhanzl.com

Offline cscott

  • Senior Member
  • *****
  • Posts: 2949
  • Liked: 2054
  • Likes Given: 664
Re: Forum logging in with mobile/Tapatalk
« Reply #13 on: 02/06/2018 02:32 PM »
Tapatalk still broken for me on Android. :( My app was last updated Jan 8, so I'm pretty sure it's not a buggy app version.

I even 'unfollowed' NSF and re-added it to Tapatalk using the https link on the NSF front page, and no change.

I'm a little worried that my remove-and-retry antics are going to end up wiping tapatalk's list of subscribed forums, which is the #1 way I browse the site.  Does anyone know of/how I can see my list of subscribed forums on the desktop site?

EDIT: just retried, and it worked! I don't know if Mark fixed something or it was a bad cache entry that finally expired, but I'm a happy camper again on FH day.  Thanks!
« Last Edit: 02/06/2018 02:42 PM by cscott »

Offline NSF Webmaster

  • Administrator
  • Full Member
  • *****
  • Posts: 330
  • Almere, The Netherlands
    • NASASpaceFlight.com
  • Liked: 146
  • Likes Given: 14
Re: Forum logging in with mobile/Tapatalk
« Reply #14 on: 02/06/2018 02:44 PM »
Tapatalk still broken for me on Android. :( My app was last updated Jan 8, so I'm pretty sure it's not a buggy app version.

I even 'unfollowed' NSF and re-added it to Tapatalk using the https link on the NSF front page, and no change.

I'm a little worried that my remove-and-retry antics are going to end up wiping tapatalk's list of subscribed forums, which is the #1 way I browse the site.  Does anyone know of/how I can see my list of subscribed forums on the desktop site?

EDIT: just retried, and it worked! I don't know if Mark fixed something or it was a bad cache entry that finally expired, but I'm a happy camper again on FH day.  Thanks!

are you available for a little bit of troubleshooting to pinpoint the root cause ? I still can't reproduce it locally but really like to find out what change might have triggered this behaviour.

Thanks
Mark

Online techdude06

  • Member
  • Posts: 12
  • Ohio
  • Liked: 6
  • Likes Given: 3
Re: Forum logging in with mobile/Tapatalk
« Reply #15 on: 02/06/2018 02:46 PM »
Tapatalk still broken for me on Android. :( My app was last updated Jan 8, so I'm pretty sure it's not a buggy app version.

I even 'unfollowed' NSF and re-added it to Tapatalk using the https link on the NSF front page, and no change.

I'm a little worried that my remove-and-retry antics are going to end up wiping tapatalk's list of subscribed forums, which is the #1 way I browse the site.  Does anyone know of/how I can see my list of subscribed forums on the desktop site?

EDIT: just retried, and it worked! I don't know if Mark fixed something or it was a bad cache entry that finally expired, but I'm a happy camper again on FH day.  Thanks!



Just started working for me as well.

Thanks!

Offline cscott

  • Senior Member
  • *****
  • Posts: 2949
  • Liked: 2054
  • Likes Given: 664
Re: Forum logging in with mobile/Tapatalk
« Reply #16 on: 02/06/2018 02:48 PM »
Tapatalk still broken for me on Android. :( My app was last updated Jan 8, so I'm pretty sure it's not a buggy app version.

I even 'unfollowed' NSF and re-added it to Tapatalk using the https link on the NSF front page, and no change.

I'm a little worried that my remove-and-retry antics are going to end up wiping tapatalk's list of subscribed forums, which is the #1 way I browse the site.  Does anyone know of/how I can see my list of subscribed forums on the desktop site?

EDIT: just retried, and it worked! I don't know if Mark fixed something or it was a bad cache entry that finally expired, but I'm a happy camper again on FH day.  Thanks!

are you available for a little bit of troubleshooting to pinpoint the root cause ? I still can't reproduce it locally but really like to find out what change might have triggered this behaviour.

Thanks
Mark
Well, it's working for me again, so I maybe can't help any more.  But if you log unsuccessful logins, there should be about a dozen trying both by username (cscott) and my forum email address.  Other than maybe one or two at the start (before I switched over to the desktop site to verify that I was remembering my password correctly) they should all be legit logins. I'd love to know what the logged reason was for denying login.  And if your logs don't show any failed attempts at all, well that's another possible interesting symptom.

Offline NSF Webmaster

  • Administrator
  • Full Member
  • *****
  • Posts: 330
  • Almere, The Netherlands
    • NASASpaceFlight.com
  • Liked: 146
  • Likes Given: 14
Re: Forum logging in with mobile/Tapatalk
« Reply #17 on: 02/06/2018 02:50 PM »
Tapatalk still broken for me on Android. :( My app was last updated Jan 8, so I'm pretty sure it's not a buggy app version.

I even 'unfollowed' NSF and re-added it to Tapatalk using the https link on the NSF front page, and no change.

I'm a little worried that my remove-and-retry antics are going to end up wiping tapatalk's list of subscribed forums, which is the #1 way I browse the site.  Does anyone know of/how I can see my list of subscribed forums on the desktop site?

EDIT: just retried, and it worked! I don't know if Mark fixed something or it was a bad cache entry that finally expired, but I'm a happy camper again on FH day.  Thanks!




are you available for a little bit of troubleshooting to pinpoint the root cause ? I still can't reproduce it locally but really like to find out what change might have triggered this behaviour.

Thanks
Mark
Well, it's working for me again, so I maybe can't help any more.  But if you log unsuccessful logins, there should be about a dozen trying both by username (cscott) and my forum email address.  Other than maybe one or two at the start (before I switched over to the desktop site to verify that I was remembering my password correctly) they should all be legit logins. I'd love to know what the logged reason was for denying login.  And if your logs don't show any failed attempts at all, well that's another possible interesting symptom.

Thanks for the follow up.. I'll leave the settings the way they are for now, but I might contact one of you tomorrow (after FH :) ) to troubleshoot/test some things

Thanks
« Last Edit: 02/06/2018 02:53 PM by Chris Bergin »

Offline starsilk

  • Full Member
  • ****
  • Posts: 649
  • Denver
  • Liked: 235
  • Likes Given: 51
Re: Forum logging in with mobile/Tapatalk
« Reply #18 on: 02/06/2018 03:07 PM »
working for me again too. was down this AM.

Offline clevelas

  • Member
  • Posts: 50
  • Liked: 3
  • Likes Given: 0
Re: Forum logging in with mobile/Tapatalk
« Reply #19 on: 02/06/2018 04:51 PM »
I was asked to login on tapatalk this morning as well.  Then gave some crazy error.  Hopped on a desktop browser, and had a gateway error being reported by Cloudflare.  Saying the backend server was unavailable.  It was down probably 10 minutes or so.  Once the site came back up, Tapatalk started working as well.   So there was more to it today than just tapatalk.

Offline tyrred

  • Full Member
  • **
  • Posts: 208
  • Seattle
  • Liked: 117
  • Likes Given: 496
Re: Forum logging in with mobile/Tapatalk
« Reply #20 on: 02/06/2018 04:53 PM »
402 bad gateway for me as well on Tapatalk, had me sweating... All systems go now, no new login necessary on my end.

Offline Johnnyhinbos

  • Full Member
  • ****
  • Posts: 1377
  • Boston, MA
  • Liked: 1602
  • Likes Given: 222
Re: Forum logging in with mobile/Tapatalk
« Reply #21 on: 02/06/2018 05:01 PM »
I'm back up as well. Would be interested to know what you did to effect a fix.
John Hanzl. Author, action / adventure www.johnhanzl.com

Tags: