Author Topic: Forum Bug Reports  (Read 69972 times)

Offline russianhalo117

  • Global Moderator
  • Senior Member
  • *****
  • Posts: 8788
  • Liked: 4700
  • Likes Given: 768
Re: Forum Bug Reports
« Reply #100 on: 01/30/2023 12:26 am »
I have been trying Dark mode and it works but has a couple of issues for me.
1. Quoted text is black/dark  which is unreadable to me on the darker background. I have to highlight it to read it.
2. Not specifically dark mode but the text is smaller in the quote and that makes it even harder to read. I can't find any text size adjusters in settings so I have to use Firefox's and that screws up the boxes in the forums at the sizes I use.

Just a couple of inputs. My eyes thanks you for the dark mode.


Note AFAIR that it is an experimental L2 Early Access feature.
« Last Edit: 01/30/2023 03:15 am by russianhalo117 »

Offline Arb

  • Full Member
  • ****
  • Posts: 553
  • London
  • Liked: 514
  • Likes Given: 434
Re: Forum Bug Reports
« Reply #101 on: 02/08/2023 07:09 pm »
A trio of Topics have recently become unavailable. In the past, reorganisations always included 'redirects' to the replacement Topics. Not this on this occasion - have I missed something?

1) https://forum.nasaspaceflight.com/index.php?board=54.0 was once L2 Commercial Cargo and Crew
2) https://forum.nasaspaceflight.com/index.php?board=34.0 was once L2 Historical Section
3) https://forum.nasaspaceflight.com/index.php?board=29.0 was once L2 Orion/Future Vehicles

NB my NSF bookmarks have not been updated in a long while so some of the above Topic titles may be out of date.

Online Chris Bergin

Re: Forum Bug Reports
« Reply #102 on: 02/08/2023 07:24 pm »
A trio of Topics have recently become unavailable. In the past, reorganisations always included 'redirects' to the replacement Topics. Not this on this occasion - have I missed something?

1) https://forum.nasaspaceflight.com/index.php?board=54.0 was once L2 Commercial Cargo and Crew
2) https://forum.nasaspaceflight.com/index.php?board=34.0 was once L2 Historical Section
3) https://forum.nasaspaceflight.com/index.php?board=29.0 was once L2 Orion/Future Vehicles

NB my NSF bookmarks have not been updated in a long while so some of the above Topic titles may be out of date.

We have done some L2 spring cleaning. Please go via the menu to rebookmark.
Support NSF via L2 -- Help improve NSF -- Site Rules/Feedback/Updates
**Not a L2 member? Whitelist this forum in your adblocker to support the site and ensure full functionality.**

Offline Nomadd

  • Senior Member
  • *****
  • Posts: 8853
  • Lower 48
  • Liked: 60522
  • Likes Given: 1316
Re: Forum Bug Reports
« Reply #103 on: 03/11/2023 11:33 pm »
I can't seem to get to the forums on my Android phone anymore without scrolling down to the latest posts and entering there.  The link when you tap the three lines is gone.
Those who danced were thought to be quite insane by those who couldn't hear the music.

Offline russianhalo117

  • Global Moderator
  • Senior Member
  • *****
  • Posts: 8788
  • Liked: 4700
  • Likes Given: 768
Re: Forum Bug Reports
« Reply #104 on: 03/12/2023 03:03 am »
I can't seem to get to the forums on my Android phone anymore without scrolling down to the latest posts and entering there.  The link when you tap the three lines is gone.
Please provide your OS version and build information and your browsers version and build information.
« Last Edit: 03/12/2023 03:36 am by russianhalo117 »

Offline Nomadd

  • Senior Member
  • *****
  • Posts: 8853
  • Lower 48
  • Liked: 60522
  • Likes Given: 1316
Re: Forum Bug Reports
« Reply #105 on: 03/12/2023 03:22 am »
 Android 13. Galaxy S21. Chrome, Firefox and the Samsung browsers are all the same and all up to date. Forums is no longer a choice when you hit the menu bars on the main page. Same in Desktop site or mobile.

I get
ABOUT US
COOKIE POLICY
ADVERTISING IFO
JOIN THE TEAM
CONTENT USE POLICY
Those who danced were thought to be quite insane by those who couldn't hear the music.

Offline mn

  • Full Member
  • ****
  • Posts: 1056
  • United States
  • Liked: 902
  • Likes Given: 340
Re: Forum Bug Reports
« Reply #106 on: 03/12/2023 03:30 am »
Android 13. Galaxy S21. Chrome, Firefox and the Samsung browsers are all the same and all up to date. Forums is no longer a choice when you hit the menu bars on the main page. Same in Desktop site or mobile.

I get
ABOUT US
COOKIE POLICY
ADVERTISING IFO
JOIN THE TEAM
CONTENT USE POLICY

a picture is worth a thousand words

Offline chawleysnow

  • Member
  • Posts: 47
  • California, USA
  • Liked: 120
  • Likes Given: 47
Re: Forum Bug Reports
« Reply #107 on: 03/12/2023 05:17 am »
Same issue. iPhone 13, iOS 16.3.1, Chrome

Offline NSF Webmaster

  • Administrator
  • Full Member
  • *****
  • Posts: 370
  • Almere, The Netherlands
    • NASASpaceFlight.com
  • Liked: 219
  • Likes Given: 19
Re: Forum Bug Reports
« Reply #108 on: 03/12/2023 10:02 am »
Regarding the wrong mobile menu : that's fixed now. We are performing some maintenance tasks during this weekend and this specific issue was overlooked during one of the updates. Thanks for bringing it to our attention!

Mark

Offline IanO

  • Full Member
  • *
  • Posts: 165
  • Portland, OR
    • Portland State Aerospace Society
  • Liked: 60
  • Likes Given: 279
Re: Forum Bug Reports
« Reply #109 on: 03/29/2023 03:36 am »
Someone posted a way to search this forum using Google. If they could post that search parameter here, that would solve your search needs. Such a search parameter could be uses or adapted to other search engines.

Paste this into the Google search box:

[put your search terms here] site:forum.nasaspaceflight.com

Note, this will only work for the public threads, L2 stuff is not accessible by Google.

And the Google equivalent query to search in the title only should be

site:forum.nasaspaceflight.com intitle:"Forum Bug Reports"

See also https://churchofgoogle.org/search-tips.html
Just a friendly reminder that the "search tab" on the forum is behaving strange for the last few years. Here a screenshot of an example via NSF (left) which came up empty three times in row before a good result, versus a search engine (right).  Would be great if it was fixed.

This happens all the time for me as well.  Do we have any idea why internal forum search is breaking, and whether it can be fixed or worked around?
psas.pdx.edu

Offline Eagandale4114

  • Full Member
  • **
  • Posts: 294
  • Liked: 541
  • Likes Given: 501
Re: Forum Bug Reports
« Reply #110 on: 04/01/2023 01:03 am »
This affect NSF?

Offline leetdan

  • Full Member
  • ***
  • Posts: 370
  • Space Coast
  • Liked: 323
  • Likes Given: 284
Re: Forum Bug Reports
« Reply #111 on: 04/10/2023 02:37 pm »
The favicon has been updated to the new logo for a while now, but if you open an attached image in a new tab it will have the old favicon with the white background.

Fixed and updated to the new logo, woohoo!

Offline ChrisC

  • Veteran
  • Senior Member
  • *****
  • Posts: 2253
  • Liked: 1601
  • Likes Given: 1798
Re: Forum Bug Reports
« Reply #112 on: 04/14/2023 03:25 am »
I have a few annoying users blocked* so that their (always inane, never useful) posts don't show up in my view of forums threads.  I see that they posted a comment, but the body of their comment is replaced with a message saying I have them blocked.  It's a useful feature that I appreciate.

I noticed today that this doesn't work on mobile.  I'm logged in, and I'm seeing their posts :)  Not the end of the world, but it might be a bug.  Mobile platform is Samsung Android Chrome.

* Forum -> Profile -> Modify -> Edit Ignore List
« Last Edit: 04/14/2023 12:58 pm by ChrisC »
PSA #1: EST does NOT mean "Eastern Time".  Use "Eastern" or "ET" instead, all year round, and avoid this common error.  Google "EST vs EDT".
PSA #2: It's and its: know the difference and quietly impress grammar pedants.  Google "angry flower its" .  *** See profile for two more NSF forum tips. ***

Offline Hog

  • Senior Member
  • *****
  • Posts: 2847
  • Woodstock
  • Liked: 1703
  • Likes Given: 6877
Re: Forum Bug Reports
« Reply #113 on: 04/14/2023 03:09 pm »
I have a few annoying users blocked* so that their (always inane, never useful) posts don't show up in my view of forums threads.  I see that they posted a comment, but the body of their comment is replaced with a message saying I have them blocked.  It's a useful feature that I appreciate.

I noticed today that this doesn't work on mobile.  I'm logged in, and I'm seeing their posts :)  Not the end of the world, but it might be a bug.  Mobile platform is Samsung Android Chrome.

* Forum -> Profile -> Modify -> Edit Ignore List
TEST
Hi Chris, my name is Paul and I am a spaceflight enthusiast.
Test concluded.
Paul

Offline catdlr

  • Member
  • Senior Member
  • *****
  • Posts: 11923
  • Enthusiast since the Redstones
  • Marina del Rey, California, USA
  • Liked: 9558
  • Likes Given: 8187
Re: Forum Bug Reports
« Reply #114 on: 05/22/2023 07:11 am »
cross post...

Youtubes algorithm blocked the NSF article video for this mission for copyright reasons - at least in some countries.
Can you guys upload to a less restrictive video hoster?

https://www.nasaspaceflight.com/2023/05/axiom-2-mission/

« Last Edit: 05/22/2023 07:12 am by catdlr »
It's Tony De La Rosa, ...I don't create this stuff, I just report it.

Online Chris Bergin

Re: Forum Bug Reports
« Reply #115 on: 05/22/2023 07:01 pm »
It was fixed. But that was bad.
Support NSF via L2 -- Help improve NSF -- Site Rules/Feedback/Updates
**Not a L2 member? Whitelist this forum in your adblocker to support the site and ensure full functionality.**

Offline sanman

  • Senior Member
  • *****
  • Posts: 6007
  • Liked: 1324
  • Likes Given: 8
Re: Forum Bug Reports
« Reply #116 on: 07/19/2023 07:24 am »
The forum suddenly looks different in my (Chrome) browser. Has anything happened? Have you upgraded to new forum software?
Suddenly there are cobalt blue bars at the top and bottom of the screen. There's no usual header bar with options to select from, no search, etc.
When I look at posts, I no longer see who's liked them. Container widths for everything seem to now span the full screen width.

Re: Forum Bug Reports
« Reply #117 on: 07/25/2023 10:43 am »
I have an older iPad 2, and recently I have been getting "This website encountered a problem and had to be ...". I use Safari. I have been using my MacBook Pro the past couple of days and not experiencing the problem.

Any known issues with older iPads?

Online Chris Bergin

Re: Forum Bug Reports
« Reply #118 on: 07/25/2023 04:57 pm »
Nope. No changes from us. I'm in Chrome too, all normal.
Support NSF via L2 -- Help improve NSF -- Site Rules/Feedback/Updates
**Not a L2 member? Whitelist this forum in your adblocker to support the site and ensure full functionality.**

Offline russianhalo117

  • Global Moderator
  • Senior Member
  • *****
  • Posts: 8788
  • Liked: 4700
  • Likes Given: 768
Re: Forum Bug Reports
« Reply #119 on: 07/25/2023 05:34 pm »
I have an older iPad 2, and recently I have been getting "This website encountered a problem and had to be ...". I use Safari. I have been using my MacBook Pro the past couple of days and not experiencing the problem.

Any known issues with older iPads?
If you have an unsupported device then the devices native browser is also unsupported once you no longer receive software updates. The older the device is the more likely breaking changes occur resulting in the user needing a new device and newer browser version. I'm not sure what the minimum hardware and software specifications are for our forum's custom SMF software version compared to the normal SMF version provided by Simple Machines. Apple products are typically supported for around ten years but can vary.

A note for future reference:
For forum help please always include your devices model name, model year, operating system version and revision number (typically in parenthesis on Apple products), your browsers and their version information. With most browsers you can download what is known as an Extended Support Release or ESR to provide security and functionality updates for your unsupported device for a certain specified length of time that does not add any new browser features.

Our SMF version is 2.0.15. See Client at the bottom and make sure your browser meets SMF requirements:
https://wiki.simplemachines.org/smf/SMF2.0:Requirements_and_recommendations
I'm not sure if our custom SMF version uses any 2.1.x components, but if it does the additional following must be met:
https://wiki.simplemachines.org/smf/SMF1.1:Requirements_and_recommendations

 

Advertisement NovaTech
Advertisement Northrop Grumman
Advertisement
Advertisement Margaritaville Beach Resort South Padre Island
Advertisement Brady Kenniston
Advertisement NextSpaceflight
Advertisement Nathan Barker Photography
1